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1. Ââåäåíèå

1 Ââåäåíèå

Â äàííîì äîêóìåíòå ðàññìàòðèâàåòñÿ ïðîöåññ ðàçðàáîòêè òåñòîâ ñ èñïîëüçîâàíèåì
èíñòðóìåíòà OTK. Â êà÷åñòâå ïðèìåðà ðàññìîòðåí ïðîöåññ ðàçðàáîòêè òåñòîâ äëÿ
ìîäóëåé êîìïèëÿòîðîâ, ñîäåðæàùèõ ïðåîáðàçîâàíèÿ àðèôìåòè÷åñêèõ âûðàæåíèé.

Ìîäóëü êîìïèëÿòîðà, äëÿ êîòîðîãî ðàçðàáàòûâàþòñÿ òåñòû, áóäåì íàçûâàòü öåëåâûì
ìîäóëåì. ßçûê ïðîãðàììèðîâàíèÿ, îáðàáàòûâàåìûé ýòèì êîìïèëÿòîðîì, áóäåì
íàçûâàòü öåëåâûì ÿçûêîì.

Äîêóìåíò ñîñòîèò èç ñëåäóþùèõ ÷àñòåé:

• Îïèñàíèå öåëåâîãî ìîäóëÿ (ñì. ðàçäåë 2)

• Íà÷àëî ðàáîòû ñ ïðîåêòîì â èíñòðóìåíòå OTK (ñì. ðàçäåë 3)

• Ðàçðàáîòêà ìîäåëè (ñì. ðàçäåë 4)

• Ðàçðàáîòêà ìåïïåðà (ñì. ðàçäåë 5)

• Ðàçðàáîòêà èòåðàòîðà (ñì. ðàçäåë 6)

� Ðàçðàáîòêà èòåðàòîðîâ ìîäåëüíûõ ýëåìåíòîâ (ñì. ïîäðàçäåë 6.1)

� Çàäàíèå â ïðîåêòå èòåðàòîðà ìîäåëüíûõ ñòðóêòóð (ñì. ïîäðàçäåë 6.2)

• Ãåíåðàöèÿ òåñòîâ (ñì. ðàçäåë 7)

� Êîíôèãóðèðîâàíèå ãåíåðàòîðà (ñì. ïîäðàçäåë 7.1)

� Çàïóñê ãåíåðàòîðà (ñì. ïîäðàçäåë 7.2)

2 Îïèñàíèå öåëåâîãî ìîäóëÿ

Öåëåâûì ìîäóëåì â ðàññìàòðèâàåìîì ïðèìåðå ÿâëÿåòñÿ ìîäóëü êîìïèëÿòîðà,
êîòîðûé îñóùåñòâëÿåò íåêîòîðûå ïðåîáðàçîâàíèÿ àðèôìåòè÷åñêèõ âûðàæåíèé,
ñîäåðæàùèõ ñóììèðîâàíèå öåëûõ ÷èñåë, çíà÷åíèé öåëûõ ïåðåìåííûõ è ïîäâûðàæåíèé
òàêîãî æå âèäà.

3 Íà÷àëî ðàáîòû ñ ïðîåêòîì â èíñòðóìåíòå OTK

Äëÿ íà÷àëà ðàáîòû íàä ïðîåêòîì, êîòîðûé áóäåò ñîäåðæàòü ãåíåðàòîð òåñòîâ äëÿ
öåëåâîãî ìîäóëÿ, çàïóñòèòå èíñòðóìåíò OTK (ñì. äîêóìåíò "OTK. Óñòàíîâêà è
óäàëåíèå").

Ïðîåêò, îïèñûâàåìûé â ýòîì äîêóìåíòå, âõîäèò â êîìïëåêò ïðèìåðîâ, ïîñòàâëÿåìûõ
âìåñòå ñ OTK, è ðàñïîëîæåí â ïîäêàòàëîãå examples/expressions, ïîýòîìó âû ìîæåòå
ïðîïóñòèòü îïèñàíèå òîãî, êàê ñîçäàâàòü íîâûé ïðîåêò, à îòêðûòü óæå ñóùåñòâóþùèé
(äëÿ ýòîãî âûáåðèòå ïóíêò ìåíþ File → Open Project, âîéäèòå â óïîìÿíóòûé êàòàëîã
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è îòêðîéòå ôàéë Expressions.otk) è ïðèñòóïèòü ê ðàçðàáîòêå ìîäåëè (ñì. ðàçäåë
Ðàçðàáîòêà ìîäåëè (ñì. ðàçäåë 4)).

Äëÿ ñîçäàíèÿ íîâîãî ïðîåêòà âûáåðèòå ïóíêò ìåíþ File → New Project, çàòåì â
ïîÿâèâøåìñÿ îêíå New project (ñì. ðèñóíîê 1):

• ââåäèòå èäåíòèôèêàòîð ïðîåêòà (ïîëå Project identifier),

• âûáåðèòå áàçîâûé êàòàëîã ïðîåêòà (ïîëå Project base directory),

• ââåäèòå èìÿ ôàéëà íàñòðîåê ïðîåêòà (ïîëå Project file name),

• âûáåðèòå êîðíåâîé java-ïàêåò ïðîåêòà (ïîëå Root package name).

Ðèñ. 1: Ñîçäàíèå íîâîãî ïðîåêòà.

Äëÿ èìåí êàòàëîãîâ èñõîäíûõ ôàéëîâ ïðîåêòà (ïîëå Source directory) è
ðåçóëüòàòîâ êîìïèëÿöèè ïðîåêòà (ïîëå Build directory) èíñòðóìåíò ïðåäëîæèò
íåêîòîðûå çíà÷åíèÿ ïî óìîë÷àíèþ (ýòî, ñîîòâåòñòâåííî, ïîäêàòàëîãè src è build
áàçîâîãî êàòàëîãà ïðîåêòà), êîòîðûå ìîæíî íå èçìåíÿòü. Íàæìèòå êíîïêó Next.

Íà âòîðîì øàãå íóæíî óêàçàòü èìÿ ìîäåëè (ïî óìîë÷àíèþ � Model), à òàêæå
íåêîòîðóþ âñïîìîãàòåëüíóþ èíôîðìàöèþ. Çäåñü âåçäå ìîæíî îñòàâèòü çíà÷åíèÿ,
ïðåäëàãàåìûå ïî óìîë÷àíèþ. Íàæìèòå êíîïêó Next.

Íà òðåòüåì øàãå òàêæå ìîæíî îñòàâèòü âñå çíà÷åíèÿ ïî óìîë÷àíèþ. Íàæìèòå
êíîïêó Finish.

Â ðåçóëüòàòå â áàçîâîì êàòàëîãå ïðîåêòà áóäóò àâòîìàòè÷åñêè ñîçäàíû:
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4. Ðàçðàáîòêà ìîäåëè

• ôàéë íàñòðîåê ïðîåêòà (èìååò ðàñøèðåíèå .otk),

• êàòàëîã èñõîäíûõ ôàéëîâ ïðîåêòà,

• êàòàëîã ðåçóëüòàòîâ êîìïèëÿöèè ïðîåêòà.

Êðîìå òîãî, â êàòàëîãå èñõîäíûõ ôàéëîâ ïðîåêòà áóäåò ñîçäàí ïîäêàòàëîã äëÿ
êîðíåâîãî java-ïàêåòà ïðîåêòà, à â êîðíåâîì java-ïàêåòå ïðîåêòà áóäåò ñîçäàíà çàãîòîâêà
ôàéëà äëÿ ôîðìàëüíîãî îïèñàíèÿ ìîäåëè (ôàéë ñ èìåíåì ìîäåëè, ââåäåííîì íà âòîðîì
øàãå ñîçäàíèÿ ïðîåêòà, è ñ ðàñøèðåíèåì .tdl).

4 Ðàçðàáîòêà ìîäåëè

Òåõíîëîãèÿ òåñòèðîâàíèÿ UniTesK , ïîääåðæèâàåìàÿ OTK, ïðåäïîëàãàåò, ÷òî
òðåáîâàíèÿ ê ñòðóêòóðàì äàííûõ, îáðàáàòûâàåìûõ öåëåâûì ìîäóëåì, çàïèñàíû â ÷åòêîé
íåäâóñìûñëåííîé ôîðìå. Òàêàÿ ôîðìà ïðåäñòàâëåíèÿ òðåáîâàíèé íàçûâàåòñÿ
ôîðìàëüíûì îïèñàíèåì ìîäåëè.

Â OTK ìîäåëè ôîðìàëüíî îïèñûâàþòñÿ íà ñïåöèàëüíîì ÿçûêå TDL (Tree Description
Language).

Ó âàñ â ïðîåêòå óæå åñòü ãîòîâîå ôîðìàëüíîå îïèñàíèå ìîäåëè (ôàéë Model.tdl â
êîðíåâîì java-ïàêåòå ïðîåêòà), ïîýòîìó âû ìîæåòå ïðîïóñòèòü îïèñàíèå òîãî, êàê
ðàçðàáàòûâàòü ìîäåëü, è ïðèñòóïèòü ê ðàçðàáîòêå ìåïïåðà (ñì. ðàçäåë Ðàçðàáîòêà
ìåïïåðà (ñì. ðàçäåë 5)).

Äëÿ òîãî, ÷òîáû ñîçäàòü ôîðìàëüíîå îïèñàíèå ìîäåëè, íåîáõîäèìî ïðîàíàëèçèðîâàòü
äîêóìåíòàöèþ íà öåëåâîé ìîäóëü è ïîñòðîèòü ñâîäíóþ äèàãðàììó ìîäåëüíûõ ýëåìåíòîâ.

Â äîêóìåíòàöèè ñêàçàíî: öåëåâîé ìîäóëü îñóùåñòâëÿåò íåêîòîðûå ïðåîáðàçîâàíèÿ
àðèôìåòè÷åñêèõ âûðàæåíèé, ñîäåðæàùèõ ñóììèðîâàíèå öåëûõ ÷èñåë, çíà÷åíèé öåëûõ
ïåðåìåííûõ, à òàêæå ïîäâûðàæåíèé òàêîãî æå âèäà.

Èòàê, êàæäîå àðèôìåòè÷åñêîå âûðàæåíèå (äàëåå áóäåì ãîâîðèòü ïðîñòî
"âûðàæåíèå") ýòî ëèáî ñëîæåíèå, ëèáî çíà÷åíèå ïåðåìåííîé, ëèáî öåëîå ÷èñëî (ñì.
ðèñóíîê 2).

Ðèñ. 2: Âèäû âûðàæåíèé.

Ñëîæåíèå ñîäåðæèò äâà îïåðàíäà (ëåâûé è ïðàâûé), êàæäûé èç êîòîðûõ ÿâëÿåòñÿ
âûðàæåíèåì (ñì. ðèñóíîê 3).

Êðîìå òîãî, íåîáõîäèìî äîáàâèòü ãîëîâíîé ìîäåëüíûé ýëåìåíò, îïèñûâàþùèé îäèí
òåñò (ñì. ðèñóíîê 4).
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Ðèñ. 3: Ñòðóêòóðà ñëîæåíèÿ.

Ðèñ. 4: Ãîëîâíîé ìîäåëüíûé ýëåìåíò.

Èòàê, â ðåçóëüòàòå ïîëó÷àåòñÿ ñëåäóþùàÿ ñâîäíàÿ äèàãðàììà (ñì. ðèñóíîê 5):

Ðèñ. 5: Ñâîäíàÿ äèàãðàììà ìîäåëè.

Â ñîîòâåòñòâèè ñ ýòîé äèàãðàììîé ðàçðàáàòûâàåòñÿ ôîðìàëüíîå îïèñàíèå ìîäåëè íà
ÿçûêå TDL. Îòêðîéòå ôàéë Model.tdl â êîðíåâîì ïàêåòå ïðîåêòà. Äëÿ ýòîãî ìîæíî
èñïîëüçîâàòü ïóíêò ìåíþ File → Open File; äëÿ íàñòðîéêè êîìàíäû çàïóñêà âíåøíåãî
òåêñòîâîãî ðåäàêòîðà èñïîëüçóéòå ïóíêò ìåíþ Options → File Editor.

Â ýòîì ôàéëå íàõîäèòñÿ àâòîìàòè÷åñêè ñãåíåðèðîâàííàÿ çàãîòîâêà îïèñàíèÿ ìîäåëè:

[ translate.language = "java";
visitor.name="TestVisitor";

]
tree ru.ispras.redverst.optest.examples.expressions.Model;

header
{
import ru.ispras.redverst.optest.OtkNode;
}

Çäåñü îáúÿâëÿåòñÿ èìÿ ìîäåëè (ïîìå÷åíî êëþ÷åâûì ñëîâîì tree), à òàêæå
óêàçûâàþòñÿ íåêîòîðûå âñïîìîãàòåëüíûå äåêëàðàöèè (òåêñò â êâàäðàòíûõ ñêîáêàõ, à
òàêæå áëîê, ïîìå÷åííûé êëþ÷åâûì ñëîâîì header).

Ïîñëå áëîêà header íóæíî âñòàâèòü îïèñàíèå ìîäåëüíûõ ýëåìåíòîâ:
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5. Ðàçðàáîòêà ìåïïåðà

node Test : <OtkNode>
{

child Expr expr;
}

abstract node Expr : <OtkNode>
{}

node AddExpr : Expr
{

child Expr left;
child Expr right;

}

node Var : Expr
{}

node Int : Expr
{}

Êàæäîå îïèñàíèå ìîäåëüíîãî ýëåìåíòà íà÷èíàåòñÿ êëþ÷åâûì ñëîâîì node, ïåðåä
êîòîðûì â ñëó÷àå îáîáùåííîãî ìîäåëüíîãî ýëåìåíòà ìîæåò ñòîÿòü ìîäèôèêàòîð
abstract.

Èìÿ îáîáùåííîãî ìîäåëüíîãî ýëåìåíòà, êîíêðåòèçàöèåé êîòîðîãî ÿâëÿåòñÿ äàííûé
ìîäåëüíûé ýëåìåíò, óêàçûâàåòñÿ ïîñëå äâîåòî÷èÿ. Åñëè ìîäåëüíûé ýëåìåíò íå ÿâëÿåòñÿ
íè÷üåé êîíêðåòèçàöèåé, òî ïîñëå äâîåòî÷èÿ íóæíî íàïèñàòü '<OtkNode>'.

Ññûëêè, âåäóùèå íà äðóãèå ìîäåëüíûå ýëåìåíòû, îïèñûâàþòñÿ â âèäå ïîëåé,
ïîìå÷åííûõ êëþ÷åâûì ñëîâîì child.

Óáåäèòåñü, ÷òî ðàçðàáîòàííàÿ ìîäåëü óñïåøíî êîìïèëèðóåòñÿ. Äëÿ ýòîãî âûáåðèòå
ïóíêò ìåíþ Build → Rebuild All.

5 Ðàçðàáîòêà ìåïïåðà

Ó âàñ â ïðîåêòå åñòü ôîðìàëüíîå îïèñàíèå ìîäåëüíûõ ýëåìåíòîâ. Ãåíåðàòîð â
ïðîöåññå ðàáîòû áóäåò ñòðîèòü èç ýòèõ ìîäåëüíûõ ýëåìåíòîâ ðàçëè÷íûå ñòðóêòóðû. Äëÿ
òîãî, ÷òîáû ãåíåðàòîð ñòðîèë òåñòû äëÿ êîìïèëÿòîðà, ò.å. ãåíåðèðîâàë òåêñòû ïðîãðàìì
íà öåëåâîì ÿçûêå, íàïðèìåð, íà ÿçûêå ïðîãðàììèðîâàíèÿ C, íóæíî ïðåäîñòàâèòü
ãåíåðàòîðó èíôîðìàöèþ î òîì, êàê ìîäåëüíûå ýëåìåíòû ïðåîáðàçóþòñÿ â òåêñò íà
öåëåâîì ÿçûêå. Äëÿ ýòîé öåëè èñïîëüçóåòñÿ ñïåöèàëüíûé êîìïîíåíò ãåíåðàòîðà,
íàçûâàåìûé ìåïïåðîì.

Ìåïïåð îôîðìëÿåòñÿ â âèäå ñïåöèàëüíîãî java-êëàññà.
Ó âàñ â ïðîåêòå óæå åñòü ãîòîâûé ìåïïåð DefaultMapper, ðàñïîëîæåííûé â ïàêåòå

ru.ispras.redverst.optest.examples.expressions.mapper, ïîýòîìó âû ìîæåòå
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ïðîïóñòèòü îïèñàíèå òîãî, êàê ñîçäàâàòü íîâûé ìåïïåð, è ïðèñòóïèòü ê ðàçðàáîòêå
èòåðàòîðà (ñì. ðàçäåë Ðàçðàáîòêà èòåðàòîðà (ñì. ðàçäåë 6)).

Äëÿ ñîçäàíèÿ íîâîãî ìåïïåðà âûáåðèòå ïóíêò ìåíþ File → New File → New
Mapper, çàòåì â ïîÿâèâøåìñÿ îêíå New mapper íàæìèòå êíîïêó Add all non
abstract nodes äëÿ âûáîðà âñåõ íåàáñòðàêòíûõ ìîäåëüíûõ ýëåìåíòîâ (ñì. ðèñóíîê 6).
Ïîñëå ýòîãî íàæìèòå êíîïêó Next.

Ðèñ. 6: Âûáîð ìîäåëüíûõ ýëåìåíòîâ äëÿ ìåïïèðîâàíèÿ.

Íà âòîðîì øàãå äëÿ íàøåãî ìåïïåðà íè÷åãî çàäàâàòü íå íàäî. Íàæìèòå êíîïêó Next.
Íà òðåòüåì øàãå íóæíî ââåñòè èìÿ ïàêåòà è èìÿ êëàññà äëÿ ìåïïåðà (ñì. ðèñóíîê 7).

Ïîñëå ýòîãî íàæìèòå êíîïêó Finish.

Ðèñ. 7: Óêàçàíèå èìåíè ïàêåòà è èìåíè êëàññà ìåïïåðà.

Â ðåçóëüòàòå áóäåò ñãåíåðèðîâàí ôàéë ñ çàãîòîâêîé java-êëàññà ìåïïåðà. Åñëè
îòáðîñèòü êîììåíòàðèè è èñïîëüçîâàòü java-êîíñòðóêöèþ import äëÿ âîçìîæíîñòè
óïîòðåáëÿòü êîðîòêèå èìåíà êëàññîâ, òî ýòà çàãîòîâêà âûãëÿäèò òàê:
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5. Ðàçðàáîòêà ìåïïåðà

package ru.ispras.redverst.optest.examples.expressions.mapper;

import ru.ispras.redverst.optest.examples.expressions.Model;

public class DefaultMapper
extends ru.ispras.redverst.optest.examples.expressions.EmptyMapper

{
public void visitAddExpr( Model.AddExpr node ) {}
public void visitInt ( Model.Int node ) {}
public void visitTest ( Model.Test node ) {}
public void visitVar ( Model.Var node ) {}

}

Ýòîò êëàññ íàñëåäóåòñÿ îò âñïîìîãàòåëüíîãî êëàññà EmptyMapper, êîòîðûé
ãåíåðèðóåòñÿ àâòîìàòè÷åñêè. Äëÿ êàæäîãî ìîäåëüíîãî ýëåìåíòà, âûáðàííîãî â õîäå
ñîçäàíèÿ ìåïïåðà, èìååòñÿ ìåòîä, èìÿ êîòîðîãî îáðàçóåòñÿ ïóòåì ïðèïèñûâàíèÿ
ïðèñòàâêè 'visit' ê èäåíòèôèêàòîðó ýëåìåíòà. Êàæäûé òàêîé ìåòîä îòâå÷àåò çà
ãåíåðàöèþ òåêñòà äëÿ ñîîòâåòñòâóþùåãî ìîäåëüíîãî ýëåìåíòà.

Ðàññìîòðèì ìåòîä ìåïïåðà äëÿ ýëåìåíòà AddExpr, ìîäåëèðóþùåãî
âûðàæåíèå-ñëîæåíèå:

public void visitAddExpr( Model.AddExpr node )
{

txt( "( ${left} + ${right} )" );
}

Çäåñü äëÿ ãåíåðàöèè òåêñòà èñïîëüçóåòñÿ áèáëèîòå÷íûé ìåòîä txt, ïðåäîñòàâëÿåìûé
ðîäèòåëüñêèì êëàññîì EmptyMapper. Ýòîò ìåòîä ïðèíèìàåò íà âõîä îäèí ïàðàìåòð �
ñòðîêó ñ ãåíåðèðóåìûì òåêñòîì. Â ýòîé ñòðîêå ìîãóò ñîäåðæàòüñÿ ññûëêè íà òåêñò,
ïîëó÷àþùèéñÿ â ðåçóëüòàòå îáðàáîòêè ìåïïåðîì ïîëåé äàííîãî ìîäåëüíîãî ýëåìåíòà.
Òàêèå ññûëêè îôîðìëÿþòñÿ â âèäå ñïåöèàëüíîé êîíñòðóêöèè '${...}', ãäå â ôèãóðíûõ
ñêîáêàõ óêàçûâàåòñÿ èìÿ ïîëÿ.

Ðàññìîòðèì ìåòîäû ìåïïåðà äëÿ îñòàëüíûõ ìîäåëüíûõ ýëåìåíòîâ:
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public void visitInt( Model.Int node )
{

txt( "3" );
}

public void visitTest( Model.Test node )
{

txt( "int main() {" ); nl();
incIndent();
txt( "int n = 2;" ); nl();
txt( "int res = ${expr};" ); nl();
txt( "printf( \"%d\\n\", res );" ); nl();
popIndent();
txt( "}" ); nl();

}

public void visitVar( Model.Var node )
{

txt( "n" );
}

Ìåòîä äëÿ ýëåìåíòà Test èñïîëüçóåò êðîìå ìåòîäà txt åùå òðè áèáëèîòå÷íûõ
ìåòîäà, ïðåäíàçíà÷åííûå äëÿ ôîðìàòèðîâàíèÿ ãåíåðèðóåìîãî òåêñòà:

• ìåòîä nl íà÷èíàåò íîâóþ ñòðîêó òåêñòà,

• ìåòîä incIndent óâåëè÷èâàåò âåëè÷èíó îòñòóïà âûâîäà òåêñòà,

• ìåòîä popIndent âîññòàíàâëèâàåò ïðåäûäóùåå çíà÷åíèå âåëè÷èíû îòñòóïà.

Ìåòîä äëÿ ýëåìåíòà Test ãåíåðèðóåò òåêñò Ñ-ôóíêöèè main.
Ìåòîä äëÿ ýëåìåíòà Var ãåíåðèðóåò âçÿòèå çíà÷åíèÿ ïåðåìåííîé n. Äëÿ òîãî, ÷òîáû

îáåñïå÷èòü ñåìàíòè÷åñêóþ êîððåêòíîñòü âñåãî òåñòà, â òåêñò ôóíêöèè main ãåíåðèðóåòñÿ
êîíñòðóêöèÿ îïðåäåëåíèÿ ïåðåìåííîé n.

Äëÿ òîãî, ÷òîáû èìåòü âîçìîæíîñòü ïîëó÷èòü ðåçóëüòàò ðàáîòû îòêîìïèëèðîâàííîé
òåñòîâîé ïðîãðàììû, â òåêñò ôóíêöèè main ãåíåðèðóåòñÿ êîíñòðóêöèÿ âûâîäà
ðåçóëüòàòà âûðàæåíèÿ, ñîäåðæàùåãîñÿ â òåñòå, � âûçîâ C-ôóíêöèè printf. Äëÿ òîãî,
÷òîáû îáåñïå÷èòü ñåìàíòè÷åñêóþ êîððåêòíîñòü òåñòà, â íà÷àëå òåñòîâîé ïðîãðàììû
äîëæíà èìåòüñÿ äåêëàðàöèÿ ôóíêöèè printf. Äëÿ ãåíåðàöèè òåêñòà â íà÷àëî ôàéëà
íóæíî îïðåäåëèòü â ìåïïåðå ìåòîä beginFile:

public void beginFile()
{

txt( "#include <stdio.h>" ); nl();
}
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6. Ðàçðàáîòêà èòåðàòîðà

Óáåäèòåñü, ÷òî ðàçðàáîòàííûé ìåïïåð óñïåøíî êîìïèëèðóåòñÿ. Äëÿ ýòîãî âûáåðèòå
ïóíêò ìåíþ Build → Rebuild All.

6 Ðàçðàáîòêà èòåðàòîðà

Ó âàñ â ïðîåêòå åñòü ôîðìàëüíîå îïèñàíèå ìîäåëüíûõ ýëåìåíòîâ, à òàêæå ìåïïåð äëÿ
ïðåîáðàçîâàíèÿ ñòðóêòóð, ñîñòàâëåííûõ èç ìîäåëüíûõ ýëåìåíòîâ, â òåêñò íà öåëåâîì
ÿçûêå. Ãåíåðàòîð â ïðîöåññå ðàáîòû áóäåò ñòðîèòü ðàçëè÷íûå ñòðóêòóðû èç ìîäåëüíûõ
ýëåìåíòîâ. Â îáùåì ñëó÷àå èç ìîäåëüíûõ ýëåìåíòîâ ìîæíî ïîñòðîèòü áåñêîíå÷íî ìíîãî
ðàçëè÷íûõ ñòðóêòóð. Ðåàëüíîå ìíîæåñòâî òåñòîâ äîëæíî áûòü êîíå÷íûì. ×òîáû
ïîëó÷èòü êîíå÷íîå ÷èñëî òåñòîâ, òðåáóåòñÿ âûäåëèòü êîíå÷íîå ïîäìíîæåñòâî ìîäåëüíûõ
ñòðóêòóð è ïðåäîñòàâèòü ãåíåðàòîðó èíôîðìàöèþ î òîì, êàê ñòðîèòü ñòðóêòóðû èç
âûäåëåííîãî ïîäìíîæåñòâà. Äëÿ ýòîé öåëè èñïîëüçóåòñÿ ñïåöèàëüíûé êîìïîíåíò
ãåíåðàòîðà, íàçûâàåìûé èòåðàòîðîì.

Èòåðàòîð ìîäåëüíûõ ñòðóêòóð ñîñòîèò èç èòåðàòîðîâ ìîäåëüíûõ ýëåìåíòîâ.
Ðàçðàáîòêà èòåðàòîðà çàêëþ÷àåòñÿ â ñëåäóþùåì:

• Ðàçðàáîòêà èòåðàòîðîâ ìîäåëüíûõ ýëåìåíòîâ

• Çàäàíèå â ïðîåêòå èòåðàòîðà ìîäåëüíûõ ñòðóêòóð

6.1 Ðàçðàáîòêà èòåðàòîðîâ ìîäåëüíûõ ýëåìåíòîâ

Äëÿ êàæäîãî ìîäåëüíîãî ýëåìåíòà ðàçðàáàòûâàåòñÿ îòäåëüíûé èòåðàòîð, êîòîðûé
îôîðìëÿåòñÿ â âèäå ñïåöèàëüíîãî java-êëàññà.

Ó âàñ â ïðîåêòå óæå åñòü ãîòîâûå èòåðàòîðû ìîäåëüíûõ ýëåìåíòîâ, êîòîðûå
ðàñïîëîæåíû â ïàêåòå ru.ispras.redverst.optest.examples.expressions.iterator,
ïîýòîìó âû ìîæåòå ïðîïóñòèòü îïèñàíèå òîãî, êàê ñîçäàâàòü íîâûå èòåðàòîðû
ìîäåëüíûõ ýëåìåíòîâ, è ïðèñòóïèòü ê çàäàíèþ èòåðàòîðà ìîäåëüíûõ ñòðóêòóð (ñì.
ðàçäåë Çàäàíèå â ïðîåêòå èòåðàòîðà ìîäåëüíûõ ñòðóêòóð (ñì. ïîäðàçäåë 6.2)).

Ïðèñòóïèì ê ñîçäàíèþ èòåðàòîðîâ ìîäåëüíûõ ýëåìåíòîâ. Ñíà÷àëà ðàññìîòðèì
ïðîöåññ ñîçäàíèÿ èòåðàòîðà äëÿ ìîäåëüíûõ ýëåìåíòîâ, êîòîðûå íå èìåþò ïîëåé � â
íàøåì ñëó÷àå ýòî Var è Int. Íà÷íåì ñ èòåðàòîðà äëÿ ýëåìåíòà Var.

Äëÿ ñîçäàíèÿ íîâîãî èòåðàòîðà âûáåðèòå ïóíêò ìåíþ File → New File → New
Iterator, çàòåì â ïîÿâèâøåìñÿ îêíå New iterator âûáåðèòå èòåðàòîð äëÿ
íåàáñòðàêòíîãî ìîäåëüíîãî ýëåìåíòà � âûáåðèòå ïóíêò Non abstract node (ñì.
ðèñóíîê 8). Ïîñëå ýòîãî íàæìèòå êíîïêó Next.

Íà âòîðîì øàãå íóæíî èç âûïàäàþùåãî âûáðàòü ìîäåëüíûé ýëåìåíò, äëÿ êîòîðîãî
ñîçäàåòñÿ èòåðàòîð (ñì. ðèñóíîê 9). Äëÿ ýëåìåíòà Var çäåñü áîëüøå íè÷åãî óêàçûâàòü íå
íàäî. Íàæìèòå êíîïêó Next.

Íà òðåòüåì øàãå íóæíî ââåñòè èìÿ ïàêåòà è èìÿ êëàññà äëÿ èòåðàòîðà (ñì.
ðèñóíîê 10). Ïîñëå ýòîãî íàæìèòå êíîïêó Finish.
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Ðèñ. 8: Âûáîð âèäà èòåðàòîðà äëÿ íåàáñòðàêòíîãî ìîäåëüíîãî ýëåìåíòà.

Ðèñ. 9: Âûáîð ìîäåëüíîãî ýëåìåíòà, äëÿ êîòîðîãî ñîçäàåòñÿ èòåðàòîð

Ðèñ. 10: Óêàçàíèå èìåíè ïàêåòà è èìåíè êëàññà èòåðàòîðà.

Â ðåçóëüòàòå áóäåò ñãåíåðèðîâàí java-êëàññ èòåðàòîðà äëÿ ýëåìåíòà Var. Àíàëîãè÷íî
ñîçäàåòñÿ java-êëàññ èòåðàòîðà äëÿ ýëåìåíòà Int.

Òåïåðü ðàññìîòðèì ïðîöåññ ñîçäàíèÿ èòåðàòîðà äëÿ ìîäåëüíûõ ýëåìåíòîâ, êîòîðûå
èìåþò ïîëÿ. Íà÷íåì ñ èòåðàòîðà äëÿ ýëåìåíòà AddExpr. Íà âòîðîì øàãå ñîçäàíèÿ
ïîñëå âûáîðà èç ñïèñêà ìîäåëüíîãî ýëåìåíòà, äëÿ êîòîðîãî ñîçäàåòñÿ èòåðàòîð (ò.å.
ýëåìåíòà AddExpr), íóæíî óêàçàòü èòåðàòîðû äëÿ ïîëåé left è right ýòîãî ýëåìåíòà
(ñì. ðèñóíîê 11). Îáà ýòè ïîëÿ èìåþò òèï Expr, à çíà÷èò äëÿ íèõ íóæíî óêàçàòü
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Ðèñ. 11: Âòîðîé øàã ñîçäàíèÿ èòåðàòîðà äëÿ ìîäåëüíîãî ýëåìåíòà, èìåþùåãî ïîëÿ.

èòåðàòîð ìîäåëüíûõ ýëåìåíòîâ òèïà Expr. Ïîñêîëüêó èòåðàòîð äëÿ ìîäåëüíîãî
ýëåìåíòà Expr åùå íå ñîçäàí, ìîæíî âûáðàòü èòåðàòîð äëÿ êàêîé-íèáóäü åãî
êîíêðåòèçàöèè, íàïðèìåð äëÿ ýëåìåíòà Int. Âûäåëèòå ïîëå left, íàæìèòå êíîïêó Set
iterator è â ïîÿâèâøåìñÿ îêíå âûáåðèòå â âûïàäàþùåì ñïèñêå java-êëàññ
ru.ispras.redverst.optest.examples.expressions.iterator.IntIterator (ñì.
ðèñóíîê 12). Àíàëîãè÷íî óêàæèòå èòåðàòîð äëÿ ïîëÿ right. Ïîñëå ýòîãî íàæìèòå êíîïêó

Ðèñ. 12: Âûáîð èòåðàòîðà äëÿ ïîëÿ.

Next è ââåäèòå èìÿ ïàêåòà è èìÿ êëàññà äëÿ èòåðàòîðà. Ïîñëå ýòîãî íàæìèòå êíîïêó
Finish.

Â ðåçóëüòàòå áóäåò ñãåíåðèðîâàí java-êëàññ èòåðàòîðà äëÿ ýëåìåíòà AddExpr.
Ïîñêîëüêó äëÿ ïîëåé ýòîãî ýëåìåíòà áûë óêàçàí èòåðàòîð ýëåìåíòà Int, òî ïîëó÷èâøèéñÿ
èòåðàòîð áóäåò ñòðîèòü ìîäåëüíûå ñòðóêòóðû, ñîîòâåòñòâóþùèå ñëîæåíèþ öåëûõ ÷èñåë.
Äëÿ òîãî, ÷òîáû ñòðîèëèñü ìîäåëüíûå ñòðóêòóðû, ñîîòâåòñòâóþùèå ñëîæåíèþ
ðàçëè÷íûõ âûðàæåíèé, íóæíî, ÷òîáû äëÿ ïîëåé ýòîãî ýëåìåíòà áûë óêàçàí èòåðàòîð
ýåëåìåíòà Expr. Ïðåæäå âñåãî íóæíî ñîçäàòü òàêîé èòåðàòîð.

Ýëåìåíò Expr ÿâëÿåòñÿ îáîáùåííûì ìîäåëüíûì ýëåìåíòîì. Äëÿ òîãî, ÷òîáû ñîçäàòü
äëÿ íåãî íîâûé èòåðàòîð, âûáåðèòå ïóíêò ìåíþ File → New File → New Iterator,
çàòåì â ïîÿâèâøåìñÿ îêíå New iterator âûáåðèòå èòåðàòîð äëÿ îáîáùåííîãî
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ìîäåëüíîãî ýëåìåíòà � âûáåðèòå ïóíêò Generalized node (ñì. ðèñóíîê 13). Ïîñëå ýòîãî
íàæìèòå êíîïêó Next.

Ðèñ. 13: Âûáîð âèäà èòåðàòîðà äëÿ îáîáùåííîãî ìîäåëüíîãî ýëåìåíòà.

Íà âòîðîì øàãå íàäî âûáðàòü èç ñïèñêà ìîäåëüíûé ýëåìåíò, äëÿ êîòîðîãî ñîçäàåòñÿ
èòåðàòîð � ýëåìåíòà Expr. Ïîñëå ýòîãî â îêíå ïîÿâÿòñÿ âñå ýëåìåíòû-êîíêðåòèçàöèè
ýòîãî îáîáùåííîãî ýëåìåíòà (ñì. ðèñóíîê 14). Äëÿ êàæäîé êîíêðåòèçàöèè íóæíî çàäàòü

Ðèñ. 14: Îêíî çàäàíèÿ èòåðàòîðîâ ýëåìåíòîâ-êîíêðåòèçàöèé îáîáùåííîãî ìîäåëüíîãî
ýëåìåíòà.

ñîîòâåòñòâóþùèé èòåðàòîð. Äëÿ ýòîãî âûäåëèòå ýëåìåíò-êîíêðåòèçàöèþ è íàæìèòå
ïîÿâèâøóþñÿ êíîïêó Add, ïîñëå ÷åãî â ïîÿâèâøåìñÿ îêíå âûáåðèòå èç âûïàäàþùåãî
ñïèñêà èòåðàòîð è íàæìèòå êíîïêó OK (ñì. ðèñóíîê 15). Ïîñëå óñòàíîâêè èòåðàòîðîâ
âñåõ ýëåìåíòîâ-êîíêðåòèçàöèé (ñì. ðèñóíîê 16) íàæìèòå êíîïêó Next.

Íà òðåòüåì øàãå ââåäèòå èìÿ ïàêåòà è èìÿ êëàññà äëÿ èòåðàòîðà. Ïîñëå ýòîãî
íàæìèòå êíîïêó Finish.

Â ðåçóëüòàòå áóäåò ñãåíåðèðîâàí java-êëàññ èòåðàòîðà äëÿ ýëåìåíòà Expr.
Òåïåðü âåðíåìñÿ ê èòåðàòîðó äëÿ ýëåìåíòà AddExpr. Ðàññìîòðèì java-êîä

êîíñòðóêòîðà ýòîãî èòåðàòîðà. Ýòîò êîíñòðóêòîð ñîäåðæèò try-áëîê, â êîòîðîì
ïðîèçâîäèòñÿ èíèöèàëèçàöèÿ îáúåêòà main_iterator. Åñëè îòáðîñèòü êîììåíòàðèè è
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Ðèñ. 15: Çàäàíèå èòåðàòîðà ýëåìåíòà-êîíêðåòèçàöèè îáîáùåííîãî ìîäåëüíîãî ýëåìåíòà.

Ðèñ. 16: Çàäàííûå èòåðàòîðû ýëåìåíòîâ-êîíêðåòèçàöèé îáîáùåííîãî ìîäåëüíîãî ýëåìåíòà.

èñïîëüçîâàòü java-êîíñòðóêöèþ import äëÿ âîçìîæíîñòè óïîòðåáëÿòü êîðîòêèå èìåíà
êëàññîâ, òî java-êîä èíèöèàëèçàöèè îáúåêòà main_iterator âûãëÿäèò òàê:

main_iterator = IteratorFactory.createDetailsIterator
( OTK.getIteratorProperty( "iterator.AddExprIterator.combination" )
, new ValueIterator[]

{ /* left */ new IntIterator()
, /* right */ new IntIterator()
}

);

Ýòîò êîä íóæíî äîðàáîòàòü, ÷òîáû ñòðîèëèñü ìîäåëüíûå ñòðóêòóðû,
ñîîòâåòñòâóþùèå ñëîæåíèþ ðàçëè÷íûõ âûðàæåíèé, à íå òîëüêî öåëûõ ÷èñåë. Äëÿ ýòîãî
íóæíî óêàçàòü äëÿ åãî ïîëåé èòåðàòîð ýåëåìåíòà Expr.

Îäíàêî, åñëè çàìåíèòü â ïðîöèòèðîâàííîì êîäå êîíñòðóêöèþ new IntIterator() íà
êîíñòðóêöèþ new ExprIterator(), òî âî âðåìÿ ðàáîòû ãåíåðàòîðà âîçíèêíåò
áåñêîíå÷íàÿ ðåêóðñèÿ: äëÿ ñîçäàíèÿ èòåðàòîðà ýëåìåíòà AddExpr íóæíî ñîçäàòü
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èòåðàòîð ýëåìåíòà Expr, äëÿ ñîçäàíèÿ êîòîðîãî â ñâîþ î÷åðåäü íóæíî ñîçäàòü äðóãîé
èòåðàòîð ýëåìåíòà AddExpr, è ò.ä. Äëÿ ðåøåíèÿ ýòîé ïðîáëåìû èòåðàòîðîì
ïðåäîñòàâëÿåòñÿ ìåòîä getDepth. Íà íåêðèòè÷åñêîé ãëóáèíå, ò.å. êîãäà getDepth() > 0,
íóæíî âûçûâàòü êîíñòðóêöèþ new ExprIterator(), à íà êðèòè÷åñêîé ãëóáèíå âûçûâàòü
êîíñòðóêöèþ new IntIterator(). Äîðàáîòàííûé òàêèì îáðàçîì java-êîä èíèöèàëèçàöèè
îáúåêòà main_iterator âûãëÿäèò òàê:

main_iterator = IteratorFactory.createDetailsIterator
( OTK.getIteratorProperty( "iterator.AddExprIterator.combination" )
, new ValueIterator[]

{ getDepth() > 0 ?
(ValueIterator)new ExprIterator() :
(ValueIterator)new IntIterator()

, getDepth() > 0 ?
(ValueIterator)new ExprIterator() :
(ValueIterator)new IntIterator()

}
);

Èòåðàòîð äëÿ ýëåìåíòà AddExpr ãîòîâ.
Èòåðàòîð äëÿ ìîäåëüíîãî ýëåìåíòà Test ñîçäàåòñÿ àíàëîãè÷íî èòåðàòîðó äëÿ Var ñ

óêàçàíèåì íà âòîðîì øàãå äëÿ ïîëÿ expr èòåðàòîðà ýëåìåíòà Expr.
Óáåäèòåñü, ÷òî ðàçðàáîòàííûå èòåðàòîðû óñïåøíî êîìïèëèðóåòñÿ. Äëÿ ýòîãî

âûáåðèòå ïóíêò ìåíþ Build → Rebuild All.

6.2 Çàäàíèå â ïðîåêòå èòåðàòîðà ìîäåëüíûõ ñòðóêòóð

Ïîñëå ñîçäàíèÿ èòåðàòîðîâ äëÿ ìîäåëüíûõ ýëåìåíòîâ íóæíî çàäàòü â ïðîåêòå
èòåðàòîð ìîäåëüíûõ ñòðóêòóð, êîòîðûé áóäåò èñïîëüçîâàòüñÿ ïðè ðàáîòå ãåíåðàòîðà.

Ó âàñ â ïðîåêòå èòåðàòîð ìîäåëüíûõ ñòðóêòóð óæå çàäàí, ïîýòîìó âû ìîæåòå
ïðîïóñòèòü îïèñàíèå òîãî, êàê çàäàâàòü èòåðàòîð ìîäåëüíûõ ñòðóêòóð, è ïðèñòóïèòü ê
ãåíåðàöèè òåñòîâ (ñì. ðàçäåë Ãåíåðàöèÿ òåñòîâ (ñì. ðàçäåë 7)).

Äëÿ òîãî, ÷òîáû çàäàòü â ïðîåêòå èòåðàòîð ìîäåëüíûõ ñòðóêòóð, âûáåðèòå ïóíêò
ìåíþ Project → Default iterator, â ïîÿâèâøåìñÿ îêíå ââåäèòå èìÿ ïàêåòà è èìÿ
êëàññà äëÿ èòåðàòîðà ìîäåëüíûõ ñòðóêòóð, à òàêæå â ïîëå Tree iterator class âûáåðèòå
èç âûïàäàþùåãî ñïèñêà èìÿ èòåðàòîðà ãîëîâíîãî ìîäåëüíîãî ýëåìåíòà, ò.å. ýëåìåíòà
Test (ñì. ðèñóíîê 17). Ïîñëå ýòîãî íàæìèíå êíîïêó OK.

Óáåäèòåñü, ÷òî ïðîåêò óñïåøíî êîìïèëèðóåòñÿ. Äëÿ ýòîãî âûáåðèòå ïóíêò ìåíþ
Build → Rebuild All.

7 Ãåíåðàöèÿ òåñòîâ

Ó âàñ â ïðîåêòå åñòü ôîðìàëüíîå îïèñàíèå ìîäåëüíûõ ýëåìåíòîâ, ìåïïåð äëÿ
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Ðèñ. 17: Çàäàíèå èòåðàòîðà ìîäåëüíûõ ñòðóêòóð.

ïðåîáðàçîâàíèÿ ñòðóêòóð, ñîñòàâëåííûõ èç ìîäåëüíûõ ýëåìåíòîâ, â òåêñò íà öåëåâîì
ÿçûêå, à òàêæå èòåðàòîð ìîäåëüíûõ ñòðóêòóð.

Ïåðåä çàïóñêîì ãåíåðàòîðà ïðîåêò íóæíî îòêîìïèëèðîâàòü. Äëÿ ýòîãî âûáåðèòå
ïóíêò ìåíþ Build → Rebuild All.

Ãåíåðàöèÿ òåñòîâ çàêëþ÷àåòñÿ â ñëåäóþùåì:

• Êîíôèãóðèðîâàíèå ãåíåðàòîðà (ñì. ïîäðàçäåë 7.1)

• Çàïóñê ãåíåðàòîðà (ñì. ïîäðàçäåë 7.2)

7.1 Êîíôèãóðèðîâàíèå ãåíåðàòîðà

Ãåíåðàòîð â ïðîöåññå ðàáîòû áóäåò ñòðîèòü ðàçëè÷íûå ñòðóêòóðû èç ìîäåëüíûõ
ýëåìåíòîâ è ïðåîáðàçîâûâàòü èõ â òåêñò íà öåëåâîì ÿçûêå. Ïåðåä çàïóñêîì ãåíåðàòîð
íóæíî ñêîíôèãóðèðîâàòü: óêàçàòü èòåðàòîð ìîäåëüíûõ ñòðóêòóð è ìåïïåð.

Ó âàñ â ïðîåêòå óæå èìååòñÿ ãîòîâàÿ êîíôèãóðàöèÿ, ïîýòîìó âû ìîæåòå ïðîïóñòèòü
îïèñàíèå òîãî, êàê ñîçäàâàòü íîâóþ êîíôèãóðàöèþ, è ïðèñòóïèòü ê çàïóñêó ãåíåðàòîðà
(ñì. ðàçäåë Çàïóñê ãåíåðàòîðà (ñì. ïîäðàçäåë 7.2)).

Äëÿ ñîçäàíèÿ íîâîé êîíôèãóðàöèè âûáåðèòå ïóíêò ìåíþ Run → New
Configuration, çàòåì â ïîÿâèâøåìñÿ îêíå New configuration ââåäèòå èäåíòèôèêàòîð
êîíôèãóðàöèè (ñì. ðèñóíîê 18). Ïîñëå ýòîãî íàæìèòå êíîïêó Next. Ïîÿâèòñÿ îêíî
êîíôèãóðàöèè. Ðàçðàáîòàííûå â âàøåì ïðîåêòå êîìïîíåíòû ãåíåðàòîðà íóæíî óêàçàòü â
êîíôèãóðàöèè â âèäå ïîäêëþ÷àåìûõ ìîäóëåé (plugin). Ïðåæäå âñåãî íóæíî óêàçàòü
èòåðàòîð ìîäåëüíûõ ñòðóêòóð. Äëÿ ýòîãî ââåäèòå èìÿ ïîäêëþ÷àåìîãî ìîäóëÿ èòåðàòîðà
â ïîëå Test iterator plugin ïîñëå ÷åãî íàæìèòå êíîïêó Default, ðàñïîëîæåííóþ
ñïðàâà îò ýòîãî ïîëÿ. Â ðåçóëüòàòå â îêíå êîíôèãóðàöèè ïîÿâèòñÿ ïàïêà ñ èíôîðìàöèåé
î ïîäêëþ÷àåìîì ìîäóëå äëÿ èòåðàòîðà (ñì. ðèñóíîê 19).
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Ðèñ. 18: Ñîçäàíèå íîâîé êîíôèãóðàöèè.

Ðèñ. 19: Çàäàíèå â êîíôèãóðàöèè èòåðàòîðà ìîäåëüíûõ ñòðóêòóð.

Äëÿ óêàçàíèÿ ìåïïåðà íóæíî îòêðûòü îêíî ðåäàêòèðîâàíèÿ ñïèñêà îáðàáîò÷èêîâ
ìîäåëüíûõ ñòðóêòóð. Íàæìèòå êíîïêó Edit, ðàñïîëîæåííóþ ñïðàâà îò ïîëÿ Backend
list. Â ïîÿâèâøåìñÿ îêíå â ïðàâîé êîëîíêå êíîïîê íàæìèòå øåñòóþ ñâåðõó êíîïêó, äëÿ
êîòîðîé ïîÿâëÿåòñÿ âñïëûâàþùàÿ ïîäñêàçêà 'Insert new standard printer before
selected item' (ñì. ðèñóíîê 20). Â íîâîì ïîÿâèâøåìñÿ îêíå ââåäèòå èìÿ ïîäêëþ÷àåìîãî
ìîäóëÿ ïðèíòåðà â ïîëå Printer plugin name, âûáåðèòå java-êëàññ ìåïïåðà èç
âûïàäàþùåãî ñïèñêà â ïîëå Mapper class name, à òàêæå ââåäèòå èìÿ ïîäêëþ÷àåìîãî
ìîäóëÿ ìåïïåðà â ïîëå Mapper plugin name (ñì. ðèñóíîê 21). Ïîñëå ýòîãî íàæìèòå
êíîïêó OK. Â îêíå ðåäàêòèðîâàíèÿ ñïèñêà îáðàáîò÷èêîâ ìîäåëüíûõ ñòðóêòóð òàêæå
íàæìèòå êíîïêó OK.

Òåïåðü â êîíôèãóðàöèè óêàçàíû âñå íåîáõîäèìûå ïîäêëþ÷àåìûå ìîäóëè.
Èíôîðìàöèÿ î íèõ îòîáðàæàåòñÿ â âèäå ïàïîê ê îêíå êîíôèãóðàöèè (ñì. ðèñóíîê 22).

Òåïåðü íóæíî ñêîíôèãóðèðîâàòü ïðèíòåð. Â îêíå êîíôèãóðàöèè â ïàïêå äëÿ
ïîäêëþ÷àåìîãî ìîäóëÿ printer îòêðîéòå ïàïêó ñâîéñòâ Properties. Ïðèíòåð èìååò
÷åòûðå ñâîéñòâà (ñì. ðèñóíîê 23):

• output.dir � êàòàëîã äëÿ âûâîäà ôàéëîâ ñ òåñòàìè;

• file.prename � íà÷àëî èìåí ãåíåðèðóåìûõ ôàéëîâ;
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Ðèñ. 20: Âñòàâêà ïðèíòåðà â ñïèñîê îáðàáîò÷èêîâ ìîäåëüíûõ ñòðóêòóð.

Ðèñ. 21: Óêàçàíèå ìåïïåðà â ïðèíòåðå.

• file.postname � êîíåö èìåí ãåíåðèðóåìûõ ôàéëîâ;

• file.size � êîëè÷åñòâî òåñòîâ, ãåíåðèðóåìûõ â îäèí ôàéë.

Âûáåðèòå êàòàëîã äëÿ âûâîäà ôàéëîâ ñ òåñòàìè. Äëÿ ýòîãî ùåëêíèòå äâà ðàçà ëåâîé
êíîïêîé ìûøè (íóæåí íå "äâîéíîé ùåë÷îê"êíîïêè ìûøè, à èìåííî íàæàòèå äâà ðàçà
"ìåäëåííî", ò.å. ñ íåêîòîðûì ïåðåðûâîì ìåæäó íàæàòèÿìè) ïî ñòðîêå ñâîéñòâà
output.dir, à çàòåì íàæìèòå ïîÿâèâøóþñÿ ñïðàâà â ýòîé ñòðîêå êíîïêó îáçîðà
êàòàëîãîâ âàøåé ôàéëîâîé ñèñòåìû.
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Ðèñ. 22: Îêíî êîíôèãóðàöèè ïîñëå óêàçàíèÿ âñåõ ïîäêëþ÷àåìûõ ìîäóëåé.

Ðèñ. 23: Êîíôèãóðèðîâàíèå ïðèíòåðà.

Ââåäèòå íà÷àëî èìåí ãåíåðèðóåìûõ ôàéëîâ â ïîëå file.prename.
Ââåäèòå êîíåö èìåí ãåíåðèðóåìûõ ôàéëîâ â ïîëå file.postname.
Óñòàíîâèòå êîëè÷åñòâî òåñòîâ, ãåíåðèðóåìûõ â îäèí ôàéë, ðàâíûì 1.
Ïðèíòåð ñêîíôèãóðèðîâàí (ñì. ðèñóíîê 23).
Òåïåðü êîíôèãóðàöèÿ ïîëíîñòüþ ãîòîâà. Íàæìèòå â îêíå ðåäàêòèðîâàíèÿ

êîíôèãóðàöèè êíîïêó Save, çàòåì íàæìèòå êíîïêó Close.

7.2 Çàïóñê ãåíåðàòîðà

Ïåðåä çàïóñêîì ãåíåðàòîðà óáåäèòåñü, ÷òî â êîíôèãóðàöèè óêàçàí êîððåêòíûé
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êàòàëîã äëÿ âûâîäà ôàéëîâ ñ òåñòàìè. Äëÿ ýòîãî âûáåðèòå ïóíêò ìåíþ Run → Edit
Configuration, çàòåì â ïîÿâèâøåìñÿ îêíå Edit configuration îòêðîéòå ïàïêó printer,
â íåé îòêðîéòå ïîäïàïêó Properties (ñì. ðèñóíîê 23), ùåëêíèòå äâà ðàçà ëåâîé êíîïêîé
ìûøè (íóæåí íå "äâîéíîé ùåë÷îê"êíîïêè ìûøè, à èìåííî íàæàòèå äâà ðàçà
"ìåäëåííî", ò.å. ñ íåêîòîðûì ïåðåðûâîì ìåæäó íàæàòèÿìè) ïî ñòðîêå ñâîéñòâà
output.dir, à çàòåì íàæìèòå ïîÿâèâøóþñÿ ñïðàâà â ýòîé ñòðîêå êíîïêó îáçîðà
êàòàëîãîâ âàøåé ôàéëîâîé ñèñòåìû è âûáåðèòå ïîäõîäÿùèé êàòàëîã äëÿ òåñòîâ. Ïîñëå
ýòîãî íàæìèòå â îêíå ðåäàêòèðîâàíèÿ êîíôèãóðàöèè êíîïêó Save, à çàòåì íàæìèòå
êíîïêó Close.

Äëÿ çàïóñêà ãåíåðàòîðà âûáåðèòå ïóíêò ìåíþ Run → Start Generator. Â
ïîÿâèâøåìñÿ îêíå Generate áóäåò îòîáðàæàòüñÿ õîä ãåíåðàöèè òåñòîâ � êàæäîé òî÷êå
ñîîòâåòñòâóåò îäèí ñãåíåðèðîâàííûé ôàéë. Ïðè óñïåøíîì çàâåðøåíèè ãåíåðàöèè áóäåò
âûâåäåíî êîëè÷åñòâî ñãåíåðèðîâàííûõ òåñòîâ (ñì. ðèñóíîê 24). Íàæìèòå êíîïêó Close.

Ðèñ. 24: Óñïåøíîå çàâåðøåíèå ãåíåðàöèè òåñòîâ.

Ïî óìîë÷àíèþ ãåíåðàòîðîì áóäóò ñîçäàíû òåñòû, ó êîòîðûõ ãëóáèíà âëîæåííîñòè
ïîäâûðàæåíèé íå ïðåâûøàåò 2. Äëÿ òîãî, ÷òîáû ñãåíåðèðîâàòü òåñòû ñ áîëüøåé
ãëóáèíîé âëîæåííîñòè ïîäâûðàæåíèé, íóæíî óêàçàòü çíà÷åíèå ýòîé ãëóáèíû â
êîíôèãóðàöèè. Äëÿ ýòîãî âûáåðèòå ïóíêò ìåíþ Run → Edit Configuration, çàòåì â
ïîÿâèâøåìñÿ îêíå Edit configuration îòêðîéòå ïàïêó iterator, â íåé îòêðîéòå
ïîäïàïêó Properties, ùåëêíèòå äâà ðàçà ëåâîé êíîïêîé ìûøè ïî ñòðîêå ñâîéñòâà
AddExpr.depth, ïîñòàâüòå ãàëî÷êó â êâàäðàòèêå ñëåâà â ýòîé ñòðîêå è èçìåíèòå
çíà÷åíèå ñâîéñòâà (ñì. ðèñóíîê 25). Ïîñëå ýòîãî íàæìèòå â îêíå ðåäàêòèðîâàíèÿ
êîíôèãóðàöèè êíîïêó Save, à çàòåì íàæìèòå êíîïêó Close. Ïîñëå ýòîãî çàïóñòèòå
ãåíåðàòîð, äëÿ ÷åãî âûáåðèòå ïóíêò ìåíþ Run → Start Generator.
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Ðèñ. 25: Èçìåíåíèå çíà÷åíèÿ ñâîéñòâà èòåðàòîðà ìîäåëüíûõ ñòðóêòóð.
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